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General Computer Layout 
Our computer network can be roughly separated into five parts: (1) ADSC data collection computers, 
(2) MD2 operation computer, (3) two computers for the beamline control, (4) three computers for data 
processing and structure solution and (5) data storage and backup. You should use computers in 
category (1), (2) or (3) ONLY for data collection and the beamline controls (no Web browsing, 
games, music etc). In addition, there are two more shared computers in the back user area. 

The control room for 24ID-E station is pictured in Figure 1. 

 

    

Figure 1. General view of the main working area on 24 ID-E. 

MD-2 Operation computer is NOT used by users. Two programs should be always running: 
MD2_RPC_comwrapper Server (usually minimized to the task bar) and MD2 Control GUI NE-CAT2. 

Check Troubleshooting section on how to restart the whole MD-2 and how to restart ALL user 
beamline control software. 

ADSC computer is used only for current diffraction image visualization, using ADXV software. To 
start the ADSC software: find on the desktop a diamond-shaped icon called “AutoADSC” and double –
click on it, a new window with green font will open. Next on “auxiliary” computer in the CONSOLE 
script under detector tab select “UTILITIES” and choose “Restart ADSC system” – a new GUI will 
start after in a while. All other functions of the ADSC GUI are for exclusive use of the beamline 
personnel. 

Beamline Control Computers The beamline control software runs on two different Windows 
computers, namely "master" and "auxiliary". The video from these computers is output to 3 
rightmost LCD monitors (see picture above). You can switch between these computers by pressing 
corresponding buttons on KVM switch (below the top shelf). All user operations are done on 
"auxiliary" computer only. 

To start the main script, find on the desktop the icon EXEC_Intel (or it 
may be called EXECUTOR).  



A new empty window will appear.  

Click on File and choose "Prior .CXE 
Selection", drag the mouse to the right to 
select the script 
"C:\CONHEAP\PHII_MD2_FULL_REDIS_N
EW.CXE". As the beamline is under constant 
development, the current name of the script 
may be different; the support beamline 
personnel will notify you. Click on "Execution 
Option" and choose "Execute Script"  

 

Now you should see the new window coming (Figure 2): 

 
Figure 2. MD2 support table script PHII_MD2_FULL_REDIS.cxe" 

This is your MAIN working area and you can do all following functions: 

• Access the crystal centering interface (3-click alignment, focusing, lights, snapshots collection, 
basic robot operations) XTAL CENTERING tab 

• Access data collections interface with different protocols DATA COLLECTION tab 
• adjust the orientation of the MD2 table relative to the beam (MD2 AUTOALIGN)  
• change the size of the beam aperture (MD2 APPERTURE); check he current aperture value  
• maximize the flux and optimize the beam position ( TRIM_X and TRIM_Y POSITIONs);  
• Access the robot control script by pressing ROBOT LOADER (see next chapter)  
• move in/out the sample sensor RETRACT/INSERT SS;  
• retract/insert the cold-steam nose RETRACT/INSERT CRYO;  
• open/close sample shutter; check the status of the main shutter; get APS ring status  
• define the desired beam flux (TRANSMISSION button)  
• check the current values of the energy, flux (arbitrary units), transmission ( in % of the full 

beam), detector distance, ADSC state and the status of the beamline software (busy/ready)  
• access several functions of the script running on the MASTER computer (MASTER OPS)  
• change cold stream parameters (be very careful! ) (CRYOJET button)  
• read several parameters (to communicate with you support personnel, if requested)  
• save or recover the tune state of the beamline , or the current state of the MD2 table  
• recover from the shutter errors –WAKE SHUTTER 



Robot Operations 

Inside the Hutch 
Inside the experimental hutch there are two computers, connected to one monitor: use “SCROLL”,  
“SCROLL” and the “down arrow” button on the keyboard to switch between MD2 operation 
computer and beamline control computer, which is running robotic application script. User should 
only operate one computer at a time: either inside or outside the hutch. 

 
Figure 3. The main working window for all robotic applications INSIDE the hutch  

Unload/Load Pucks   
  

1. Remove any mounted crystals on the goniometer, either manually or pressing DISMOUNT button. 

2. Make sure the MD2 is in “SAMPLE TRANSFER” mode and all covers are closed on MD2. Make 
sure that the BUSY light is dim (not bright red) and ROBOT READY. 

3. Click on PARK/SAFE, select "park gripper" and script will ask you to confirm. Click YES. The 
robot script will then perform several sanity checks: 
    *  If MD2 is not closed, then the capillary/beamstop will be retracted under the cover. 
    *  Sample on the Goniomter - The sample sensor will detect if there is a pin on the goniometer. If a 
sample is present, the robot script will ask you to remove the sample or allow the robot to place the 
sample back in the dewar. If you choose to manually remove, the sample sensor will retract to allow 
you to reach the pin. The sample sensor may be manually moved– click on “SS PROBE” 
Once the spindle is unoccupied, and all covers are closed, the robot script will park the gripper. 

You should wait and NOT touch anything before the gripper stops in Park Position (facing goniometer). 
 
4.  Click  UN/LOAD PUCK. Next a new popup window will appear – select a puck position (A B C 
D) or CANCEL the operation. 

After puck selection, the dewar will rotate that position directly under the opening and allow for 



placement of a puck. There are four positions in the dewar: A, B, C, and D. Keep track of which puck 
goes in which position. After the gripper has been parked, you can access the dewar. 

5.  Turn off the fan for better viewing. The switch for the fan is on the top of light-yellow box (left 
figure). Before pucks can be loaded, the lid must be removed and placed in the lid resting location (on 
the fan control box): see figures below. 

  

  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
6. Remove the puck from the shipping cane. Turn over the puck so that the thick part of the puck is face 
up. Attach the puck pusher to the puck. Orient the puck so that the notch is facing the center of the 
dewar. Load your puck into the dewar by lowering into the liquid nitrogen and feeling for engagement 
of the notch with the pin. It is recommended to slightly tilt the pusher toward the center of the dewar. 
When the puck is engaged, then it will not move in the dewar and the puck pusher will be 
perpendicular to the opening of the dewar. The puck will also be seated inside all three pins. Once the 
puck is engaged, push down with the plunger (of the puck pusher) to separate the two pieces of the 
puck. Then lift straight up in order to avoid disturbing the pins. Visually check the alignment of ALL 
pins, use long (and cooled) forceps to place properly tipped over pins. 
 
7. After loading your puck into the dewar, select the next position by first clicking UN/LOAD PUCK, 
confirm, and then choosing the next position. Due to the sanity checks, this step is slow. Repeat steps 3-
6, until up to four pucks are in the dewar. 
 
8. Once all your pucks are loaded, replace the lid on the dewar (make sure the pin on the dewar is 
engaged in the lid) and turn the fan back on. 



9. You must cool the gripper before samples can be mounted. Click COOL GRIPPER. The gripper 
should enter the dewar and begin cooling. Once the proper temperature has been achieved, you will be 
able to select a puck (click A, B, C or D) and a sample (click a number in the puck picture). Now, 
sample mounting can proceed. It is recommended to mount the first crystal inside the hutch, to check 
proper alignment of the robot. Once PuckID and Sample# changed color to yellow/cyan – press 
“MOUNT” button and watch the robot mounting the first crystal. 

Now all robot operation should be done OUTSIDE the hutch, using the robot script running on 
auxiliary computer.  

Outside the Hutch 
All robot operation can done OUTSIDE the hutch, using either the XTAL CENTERING tab (most 
used robot functions only) or the full robot script running on auxiliary computer – by press tab 
“ROBOT LOADER:” You should see the following screen (Figure 5): 

 
Figure 5. “ROBOT LOADER” window for all robot operations 

To mount/unmount samples: 
1. You must cool the gripper prior to mounting your first sample. Press “COOL GRIPPER”  
2. To mount your first sample click the Puck ID (A, B, C or D), then click the Sample ID (#1-16). The 



Puck ID and Sample ID colors will change to red as the robot moves to the sample location. When the 
dewar move is complete, the Puck ID color will change to yellow and the Sample ID will change to 
cyan.  
Make sure that the BUSY light is green (not bright red), ROBOT READY and the status is 
DISMOUNTED 
3. Then click MOUNT under Mount Ops.  The robot will start mount the selected crystal;            
 Be Patient – it takes ~50 seconds to finish! 
When the sample has been mounted, the voice will state, "Ready to Align Sample." At this time, you 
may align/center your crystal. The robot is still busy doing first de-icing of the gripper and second 
cooling it. Please do not click anything in the robot window at this time 
 
4. Mount Next Sample. With a sample mounted on the goniometer, you have two choices. 
    * If you wish to go to the very next sample in the puck, then click MOUNT NEXT. The robot will 
dismount the sample and mount the next sequential sample. When it is complete, the voice will state, 
"Ready to Align Sample." Be patient – it takes ~115 seconds for this step. 
    * If you wish to go to new sample in the same puck, then click the Puck ID and then select Sample 
ID of the desired sample. The puck IDs will change to red, then back to yellow and Sample ID will 
change to cyan when your selection has been accepted. The robot will dismount the current sample and 
automatically mount the chosen sample. When the mount is complete, the voice will state, "Ready to 
Align Sample." Be patient – it takes ~125 seconds for this step. 
    * If you wish to mount a crystal from a different puck, it is recommended to first click DISMOUNT 
before selecting your new sample. The robot will return the currently mounted sample to the puck. 
Once the crystal is dismounted, the BUSY light is green (not bright red), ROBOT READY, click the 
Puck ID and then select Sample ID of the desired sample. The puck IDs will change to red, then back 
to yellow and Sample ID will change to cyan, then your selection has been accepted. The robot will 
move to the new location and automatically mount the chosen sample. Be Patient – it takes ~70 
seconds to finish! The voice will then state, "Ready to Align Sample."  
    * The above behavior may be changed by checking “Automount Disabled”: in the Maintenance 
submenu – the crystal will be NOT automatically mounted after new selection. You need to click 
MOUNT to mount the selected crystal. 
 
5. Dismount -This command returns the currently mounted sample to the puck. (duration ~80 sec) 

  

6. OPTIONS  button will give you the menu with different washing scenarios. The most commonly 
used are:  

POST_WASH to wash the crystal after mounting : it instruct the robot to move the crystal back to the 
dewar, move it back and forth to remove any ice on the loop surface and mount it back. 

WASHING MACHINE – The whole dewar is strongly agitated several times to remove ice from many 
crystals at once; it is recommended to perform this operation after loading your pucks 

ENABLE PRE_WASH – Before mounting every new crystal, the gripper will be agitating up and down 
with every crystal before mounting. 

7. If a long time has passed between sample mounts (such as the duration of a long data collection), 
De-Ice Gripper and then Cool Gripper prior to dis-mounting. Ice builds up on the gripper during long 
intervals and will enter the storage dewar if not removed by de-icing. Ice in the storage dewar is drawn 
to any crystals present. 
 



8. To move the gripper into a safe state for maintenance (or after finishing the experiment) - click 
SAFE GRIPPER. 

General notes for robot trouble-free operations: 
 
Note1: The robot is SLOOOW – You can’t make it faster: every operation is a set of many instructions 
and sanity checks, which should be completed before the software can accept a new command. Please 
be patient, and wait every instruction to be properly finished. Aborting, canceling or just double-
clicking may push the system in the delirious state with long recovery time. 
Note 2: Please always watch the status of the robot system: When the robot is ready for the new 
operation/command it will display green ROBOT READY  status.  
Note 3: Do NOT do anything on MD2 control computer, when the robot is in motion. This may 
results in the severe mechanical damage to MD2. Users are liable for all damage to the MD2. 
Note 4. Double check the video feed on the computer screen above for robot gripper position (it should 
NOT be protruding into MD2) BEFORE “unlocking” the MD2 computer. 
Note 5: Please follow ALL instructions from your support personnel. Any deviations or shortcuts are 
dangerous and will lead to unpredictable results and/or physical damage of the equipment. 

 



Crystal Centering and Data Collection 
 

XTAL CENTERING is the extension of the centering mode of MD2 software with several robot 
manipulation tasks. 

 
Figure 6. General view of "XTAL CENTERING" tab 

There are several embedded operations in this window (from left top corner clockwise): 
1. Robot puck ID number (current) and the button to mount next crystal - "CHANGE"; when "BUSY' 
light is on - the robot is busy doing something, wait before clicking. You can also dismount a currently 
mounted crystal, wash it, or select pre-washing cycle. 

2. Section to control camera zoom, lighting of the crystal, and ability to acquire or view your crystal 
picture. StartServer button should be used only if the separate visual window is not started 
automatically (for beamline personnel use only). 

3. Button HOME AXES will move all value of the goniometer to the default/zero values; should not be 
used with mounted crystal: it may move it out of the cold stream. 

4. Three button to change MD2 mode: Center(default), Data collection and Sample Transfer 



5. Buttons for crystals rotation and input field for a specific phi(omega)-angle.  

6. 3-CLICK alignment tools, including alignment for crystal rastering: First, CLEAR the database (if 
necessary), second do 3-CLICK at the beginning of the raster vector, press RECORD; third, repeat 3-
CLICK centering at the end of the rastering vector, and press again RECORD, it should be number 2 in 
the left box. DISPLAY will show consequently the beginning and the end of the raster vector and 
REPLAY will repeat two alignment processes. More than two points may be created for complex cases. 
3-click alignment should be completely finished, before proceeding to the next operation. ABORT may 
be used to leave the "3-click" function. 

7. Snapshot button to collect snapshots – a snap constructor dialog will appear 

8. Buttons for manual movements of the crystal: vertical, horizontal and along the beam (out-focus 
plane). 1, 10 or 50 microns increments. 

 

DATA COLLECTION tab is used to control ADSC snapshot/data collection parameters. 

 

 
Figure 7. General view of "DATA COLLECTION" tab (with discrete run in progress) 

 

 

 



1. SNAP CONSTRUCTOR button opens the following dialog window: 

 
Here you choose all parameters for snapshots. First, you need to define the root directory for your data 
collection (unless that was not done earlier) - by clicking on "Select Browse Root". It should be the 
images sub-directory below the directory assigned to your group. Next click on "Browse" button and 
select, or create a new directory, for current project. Confirm by clicking “Update”. Next type the file 
prefix in the corresponding field. Click "Reset Index", if necessary. Select binning mode (1x1 or 2x2) 
and "Pair Snap Acquisition". When "Paired Snap Acquisition" is ON, two images separated by chosen 
offset value are collected, and LABELIT/RAPD will autoindex them together with much higher 
success. Type in starting omega/phi angle, oscillation range, exposure time, detector distance and 
transmission. Click "Update". Resolution Limits are updated once detector distance is defined and 
UPDATE is pressed.  EXECUTE leads to collection of defined snapshot(s). EXIT closes the dialog 
window and return operations to DATA COLLECTION tab window. 
Note 1: It's VERY important to click "Update" on this window and similar ones for data collection; otherwise 

previously collected image(s) may be overwritten. 

Note 2: Detector distance should be in the range of 1000 to 125 mm and exposure time should be 

a multiple of 0.5sec ONLY ( use 1 second exposure and change the flux %). 



2. RUN CONSTRUCTOR - the following dialogs opens, depending on what is selected when 
DATA MODE was pressed: 

2A. (defalt) STATIC ALIGNMENT is for usual data collection; it is much like standard ADSC 
software RUNs setup: 

 
Figure 8. Run constructor dialog 

Here you choose all parameters for standard data collection: Every field can be manually edited, as 
necessary.  First, you need to define the root directory for your data collection (unless that was not done 
earlier) - by clicking on "Select Browse Root". It should be the images sub-directory below the 
directory assigned to your group. Next click on "Browse" button and select, or create a new directory, 
for current project. Next type the file prefix in the corresponding field. Select binning mode (1x1 or 
2x2), and "Friedel Flipping" and corresponding wedge size (if required). Type in Run ID, Number of 
frames to collect, Detector distance, Transmission, Initial omega/phi angle, Oscillation range, and 
Exposure time. Repeat for another run ID, if necessary (figure above shows an example of 4 runs of 10 
degrees each).  Once all values are checked, press "Update" and "Execute".  EXECUTE leads to 
collection of defined run. EXIT close the dialog window and return operations to DATA 
COLLECTION tab window. 

ADSC data collection can be aborted by pressing "ABORT RUN" button on dialog menu or “ABORT 
RUN” button in the middle right area of “DATA COLLECTION” tab – see Figure 7.  This operation is 
slow and several images may be collected, before the run is completely aborted; please wait and do not 
press any other buttons. 



 

More complicated scenarios are defined when pressing  

"DATA MODE" button - see menu at right --> 

 

2B. STATIC ALIGNMENT – described above 

2C. BEST STRATEGY - under development. 

 

 

 

2D. DISCRETE VECTOR SCAN- discrete data collection all over the predefined vector along your 
crystal (vector is defined by recording two (or more) points along the crystal on Centering tab window 
(see above). A new setup window will appear, where you choose the aperture size, zoom view  and 
omega angle for visualization. Next select rastering parameters: Inset - the shift to the right from the 
leftmost raster vector point for start of data collection. Offset (usually more than aperture size) is the 
shift along the raster vector for next data set collection. Cycles - number of data sets to be collected. 
Phi Offset - is the shift of phi/omega angle between different data collection points. Note: for 
continuous data collection PhiOffset should be equal number of "Frames" number times "Del Omega".  

 
Pressing "GENERATE RUN DATA" will open a graphics window in the top left corner, where you 
may monitor relative positions of every run along the raster vector. Change Omega values to check the 
alignment at different orientations. Press RUN and a “Run Constructor” dialog will appear (Fig. 8). 

In the "Run Constructor" dialog window you should setup subdirectory for data collection and file 
prefix (see above), check the correctness of all runs. If there is any mistake, Click "Exit" and go back to 
"DATA MODE" and make all changes in the "DISCRETE VECTOR SCAN" dialog. If all runs are 
correct and all values are checked, press "Update" and "Execute".  EXECUTE leads to collection of 
several defined runs along your crystal. EXIT closes the dialog window and return operations to DATA 
COLLECTION tab window.  

Note: The CONTINUOUS VECTOR SCAN (described next) provides better protocol to decrease 
radiation damage, as the crystal is rotated and shifted after every collected image. 



 

2E. CONTINUOUS VECTOR SCAN – (sometimes called helical scan) – more advanced mode as 
compared with "DISCRETE VECTOR SCAN" - continuous data collection all over the predefined 
raster vector. In this mode the crystal is translated/rotated after EVERY image collected to better spread 
the radiation decay. This mode is nearly two times slower as compared to "DISCRETE VECTOR 
SCAN" mode. The following dialog window will appear where you choose the aperture size, zoom 
view and omega angle for visualization.  

 
LeftInset and RightInset are offsets from predefined raster vector ends (not zeros - if you want to 
collect data on a shorted portion of the crystal). They may be negative if you want to extend data 
collection beyond predefined vector. Omega defines the initial view of the crystal, there are +/-5 and 
+/-45 degrees rotations buttons. 

Next setup all data collection parameters based on the calculated strategy by RAPD (initial omega/phi 
angle, oscillation range, number of frames, exposure time, transmission and detector distance. 

Pressing "GENERATE RUN DATA" will open a graphics window on the left, where you may monitor 
relative positions of every image point along the raster vector, with all data collection point simulated 
in red. 

Pressing “RUN” will open ADSC data collection dialog which show only one run and it should not be 
edited (except run number and directory name). Just press "Update" and "Execute" for data collection. 

 

 



2F ALIGNMENT BY DIFFRACTION - is used to find your crystal in an opaque/non-clear loop: the 
loop is rastered by a very weak beam and the software analyzes all collected images to find one with 
the better and stronger diffraction. In the following dialog window you select the necessary parameters: 

 

 
It is recommended to use 50 micron aperture for big loop and use Omega value corresponding to plane 
of the loop. The "Metric" parameters are used by DISTIL to recognize best diffraction: "Good B Spots" 
is the best choice for now. "Overlap" defines the overlap between different search points: use a negative 
number for a sparse search. 

Press "DEFINE 1ST SCAN" and a new window will appear in the top left side, use the left mouse to 
define a rectangular search box. The final search area will be automatically defined as a convolution of 
your search box and image centering server oval covering the loop. 

Change transmission value to 1% or less and define the desired detector distance. Exposure and DelPhi 
should be 1 second and 1 degree. Press "RUN 1ST SCAN"; the system will move the loop through all 
red circles/ellipses and store the corresponding coordinates. After that on ADSC computer the 
diffraction images will appear. All images are stored in "/gpfs1/users/necat/phi_dfa_1/in" directory and 
will be deleted after exiting the ADSC tab. The message will appear when the run is complete. 

A table with processed results will appear, on which it is possible to select different points and check 
again the corresponding diffraction (can be also done by making selection in lower left graphics 
window).  Once the region of the best/strongest diffraction is found, pressing “MOVE TO” will center 
that portion of the loop for subsequent data collection. After that, you may proceed (click EXIT) and 
scan the orthogonal orientation of the loop, using the “OCCLUDED VIEW”. 

Now you need to repeat the same procedure in the orthogonal orientation:  If successful, the loop will 
be centered on the best "diffracting crystal" position. Click EXIT to close the Diffraction Alignment 
dialog. Proceed now to the data collection by pressing RUN CONSTRUCTOR  



2G. RASTER SNAP 

In the dialog window choose the aperture size, zoom  and omega angle for specific crystal orientation. 
Next select rastering parameters: LeftInset and RightInset are offsets from predefined raster vector ends 
(not zeros - if you want to collect data on a shorted portion of the crystal). Frames - number of 
snapshots to be collected along the crystal. Select starting angle, oscillation range, exposure, 
transmission and detector distance. 

Pressing "GENERATE RUN DATA" will open a data collection dialog and in a graphics window in the 
top left corner you may monitor relative positions of every run along the raster vector at the orientation 
defined by OMEGA value. You may change it for different view, and press again "GENERATE RUN 
DATA"; once satisfied, click EXECUTE and on ADSC computer you may monitor the incoming 
images. After the completion of the "raster snap" run another window with simple results will pop-up: 

You may analyze (and plot) the results table to find the best portion of the crystal. Or you may select 
any position of the crystal and press "move to" to center that portion of the crystal. 

 

2H. OCCLUDED VIEW Alignment - With very thin crystals, it is often difficult to visually discern 
the location of the crystal when in the plane of the loop.  First, you need to center at any point in the 
loop.  Second, choose the view corresponding to the plane of the loop (Occluded View), and define a 
box for scanning.  The software calculates a series of points for scanning perpendicular to the plane of 
view based on user-entered criteria, and then takes snapshots at each point.  

  

A summary of the diffraction metrics are displayed and you can select a point corresponding to 
diffraction maxima which causes the MD2 x,y,z centering stages step to the selected scan point 
coordinates.  This point can then be entered into the vector database for use in other vector-based 
scanning methods. 



Troubleshooting (in progress) 
 

1. Lost beam (no flux)  - make sure that all lights are green on PSS panel and there is beam in the ring 
(check TV screen). If the beam was lost in the ring, after the repair is done APS will announce “shutter 
permit is enabled” – after that, manually open station A shutter on a PSS panel and wait for 15 minutes 
for a monochromator to warm up.  
If there is a red light “Faults Trips” – call the floor coordinator (2-0101) to inquire about this problem. 
 Call your support beamline personnel if none of the above brings the beam. 
 

2. The most common problem during the MD2 operation is that the program MD2_comwrapper is 
dying either because of lost communications between ADSC and MD2 or because of user error. When 
MD2_comwrapper is not running the data collection is hindered. Should md2_comwrapper_server 
fails, you should wait ONE minute to md2_comwrapper_server autorestart, if not, manually restart 
MD2 software: Exit from MD2 control system (Menu-File -> Exit), wait until 
the window disappears. Kill MD2_RPC_comwrapper window, if it is present 
(check the taskbar). Double click on the desktop icon MD2_APS_v.203, wait 
until MD2 system is running (2-3 minutes) and MD2_RPC_comwrapper 
window should appear in a while and it should be minimized to the taskbar.  
 

 

3. Alarm is sounding because of liquid nitrogen nose is shifted/bumped. 
The liquid nitrogen nose is extremely sensitive and should be NEVER 
moved or adjusted. If the alarm is sounding, locate the crate for MD2 
hardware (by the wall on the left side from the MD2) and press the red 
button (shown by the yellow arrow on the Figure) . This button is called 
“press to reset table drive power”. It may be necessary to recover a 
proper position of the LN2 nose to reset the alarm. 
After pressing that red button, an alarm screen on the beamline control 
“AUXILIARY” computer should be acknowledged by clicking on the 
alarm window. Remember, you need to press two times “CTRL-CTRL” 
to switch between master and auxiliary beamline control computers. 
 

 

4. ADSC software does not collect any data after pressing “collect” – may be again the problem of 
MD2_comwrapper not running , see #2 above. Restarting ADSC software may also help.  
Next on “auxiliary” computer in the CONSOLE script under “DATA COLLECTION” tab select 
“UTILITIES” and choose “Restart ADSC system” – a new GUI will start after in a while 
It may be necessary to check for any ccd daemons still running: Exit ADSC and type “ps –e | grep ccd” 
and “ps –e | grep det”. If you see any ccd/det processes still running –kill them (kill -9 process id#). 
Now re-start again ADSC software by typing double-clicking on the green icon “AutoADSC” and 
“Restart ADCS System” from CONSOLE. 
 
5. Alarm is sounding and the detector is moving back because some foreign object went too close to the 
front of the detector. Report it to your support personnel and disable the alarm on the panel. 



 
6. If any computer is slow or frozen, the corresponding software should be restarted. To close the 
frozen EXECUTER window, press Execution Options – Abort SCRIPT in the top menu (use Ctrl-Alt-
Del only as a last resort to kill CONSOLE, (do not send any report to M$).  To start a new CONSOLE 
script, double-click on the desktop icon called “EXEC_Intel”, click on “Execution Option” and choose 
“Execute Script” 
The following software should be always running: 
Master beamline computer: EXECUTOR - C:\CONHEAP\md2_phii_full_redis.CXE script. 
Auxiliary beamline computer: EXECUTOR-  C:\CONHEAP\PHII_MD2_FULL_REDIS_new.CXE 
script; 
MD2 operation computer: MD2_comwrapper windows (in the background) and main MD2 window. 
 
7. Restarting the whole MD2 controller – this operation should be done ONLY after receiving 
authorization from your support personnel. 
Switching off sequence: 

1. Exit MD2 Control Program on the PC. 
2. Go inside E hutch and locate the MD2 control box. 
3. Press the RED Motion Supply button to stop all motors. 
4. Wait for 30 secs. 
5. Press the Main Supply to OFF position. 
Switching on sequnce: 

1. Press the Main Supply to ON position. 
2. Press the GREEN Motion Supply button to enable all motors. 
3. Wait for 30 secs. 
4. Start MD2 Control Software on the PC. 

 

8.  Restarting GALIL server  
Login to 164.54.212.142 or go inside the hutch and look for the crate behind the detector; 
Open a new shell and make sure galil is not running by typing “ps –e |grep galil” 
 Type “cd  /usr/local/galil_rpc_server”, type “./galil_rpc_server &” 
Check again if galil is running by typing “ps –e |grep galil”, close the terminal 
Master and auxiliary EXECUTOR scripts and ADSC software should be restarted after restarting galil 
server. 
 
9.  List of running servers (in progress): 
Terminal is behind the adsc detector  
164.54.212.141 – pc68_rpc_server and utilities_rpc_server 
164.54.212.142 – pc68_rpc_server and galil_rpc_server 
164.54.212.142 – serial_rpc_server.   The KVM switch is behind the monitor 
 
164.54.212.69 (Fig. 8) – pc68_rpc_server 
164.54.212.147 – mesa_rpc_, serial_rpc_ and diamond_rpc_server 
 
10. gpfs file system is not responding. -- In an emergency you may collect data directly to the local 
hard disk on the ADSC computer. Use directory /data/users/your_institution/. Only for a short period of 
time and your support person should be notified. 
 



12.  Full restart of the control software (only after receiving authorization from your support personnel 
Shutdown order for full reset on 24ID-E 
 
ADSC (Far left computer) 

 exit from GUI or type “ccdsys shutdown” at terminal 
 type two commands : “ps -e | grep ccd”  and “ps -e | grep det” at terminal 
 kill any remaining ccd/det processes by typing “kill -9 ###” (### = process id, the 1st column of the ps... results) 

  
PHII_MD2_FULL_REDIS_new.CXE on Auxiliary (3rd from left) 

 press “EXIT” button in GUI (bottom-right button panel,); or “ExecutionOptions”->”AbortScript” 
 Press “File”-> “Exit EXECUTOR” 
 
ROBOT_E.CXE inside the Hutch (robot computer, KVM switch: “SCROLL”,  “SCROLL” and the “down arrow”) 
 Press “EXIT” button in GUI window (bottom-middle button panel, top-right button) 
 Press “File”-> “Exit EXECUTOR” 
  
Md2_phii_full_redis.CXE on Master (Far right computer; to access this screen, press the button on KVM switch)  
 Press “EXIT” in GUI window (bottom-right button); or “ExecutionOptions”->”AbortScript” 
 Press “File”-> “Exit EXECUTOR” 
 
MD2 GUI (MD2 computer ; 2nd from left) 
 Exit GUI by pressing on the Menubar : “File->Exit”'; it takes ~90 sec to close 
 
Comwrapper Server (MD2 computer ; 2nd from left) (This may be stowed in the taskbar) 
 Exit by by pressing “Red Windows X” in upper right corner 
 
Restart order for full reset on 24ID-E 
 
 MD2 GUI (MD2 computer ; 2nd from left) 
–Double-click on icon on desktop “MD2_APS_v.203” 
–Wait for it to fully start (~2 minutes) 
–Comwrapper Server window will start in a while; Minimize it to the taskbar. 
 
 Robot Server  (Inside the hutch) 
-Double-click on the icon called EXECUTOR (it may be called Exec_Intel) 
Click on the File -> “ClearConsServFlag”, confirm. Don’t start any scripts for now. 
 
 md2_phii_full_redis.CXE on Master  (Far right computer; to access sit at Auxiliary and press CTRL twice) 
-Double-click on the icon called Exec_Intel (it may be called EXECUTOR) 
-Click on the File -> “ClearConsServFlag” 
–Execute script by pressing on the Menubar : “Execution Options->Execute Script” 
–Wait for it to fully start (~2 minutes); Move the whole window al the way to the right of the monitor  
 
 ROBOT_E.CXE inside the Hutch 
–Execute script by pressing on the Menubar ; “Execution Options->Execute Script” 
–Click “OK” on dialog that pops up stating that there is already a Console Server instance running. 
 
 PHII_MD2_FULL_REDIS_new.CXE on Auxiliary (3rd from left) 
- Double-click on the icon called Exec_Intel  
- Execute script by pressing on the Menubar : “Execution Options>>Execute Script” 
 
 ADSC (Far left computer) 
- double-click on green diamond-like icon “AutoADSC”; wait for terminal with green fonts to appear 
- On auxiliary computer go to “DATA COLLECTION” tab, select “UTILITIES” and choose “Restart 
ADSC system” – a new GUI will start after in a while 


